<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>3 Everyday Retail Stocks Yielding Over 3% - South Florida Reporter</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C400%2C600%2C700%7CRoboto%20Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C400%2C600%2C700%7CRoboto%20Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C400%2C600%2C700%7CRoboto%20Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic&#038;display=swap" /></noscript>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://southfloridareporter.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta property="og:image" content="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg?fit=635%2C450&ssl=1" /><link rel="icon" type="image/png" href="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/06/17014212/favicon.png">

<meta name="description" content="Like most stocks those of retailers are also down - except for these three. You may want to check them out." />
<link rel="canonical" href="https://rickorford.com/3-everyday-retail-stocks-yielding-over-3/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="3 Everyday Retail Stocks Yielding Over 3% - South Florida Reporter" />
<meta property="og:description" content="Like most stocks those of retailers are also down - except for these three. You may want to check them out." />
<meta property="og:url" content="https://rickorford.com/3-everyday-retail-stocks-yielding-over-3/" />
<meta property="og:site_name" content="South Florida Reporter" />
<meta property="article:publisher" content="https://www.facebook.com/southfloridareporter" />
<meta property="article:published_time" content="2022-06-28T23:40:10+00:00" />
<meta property="article:modified_time" content="2022-06-28T23:21:26+00:00" />
<meta property="og:image" content="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg?fit=635%2C450&ssl=1" />
<meta property="og:image:width" content="635" />
<meta property="og:image:height" content="450" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Rick Orford" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@SFLReporter" />
<meta name="twitter:site" content="@SFLReporter" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Rick Orford" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="5 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="South Florida Reporter &raquo; Feed" href="https://southfloridareporter.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="South Florida Reporter &raquo; Comments Feed" href="https://southfloridareporter.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="South Florida Reporter &raquo; 3 Everyday Retail Stocks Yielding Over 3% Comments Feed" href="https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/6.0/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wpforms-gutenberg-form-selector-css' href='https://southfloridareporter.com/wp-content/plugins/wpforms-lite/assets/css/wpforms-full.min.css?ver=1.7.4.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='easy_author_image-css' href='https://southfloridareporter.com/wp-content/plugins/easy-author-image/css/easy-author-image.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='newsletter-css' href='https://southfloridareporter.com/wp-content/plugins/newsletter/style.css?ver=7.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css' href='https://southfloridareporter.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.9.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://southfloridareporter.com/wp-content/themes/Newsmag-child/style.css?ver=1' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://southfloridareporter.com/wp-content/plugins/td-composer/legacy/Newsmag/assets/css/td_legacy_main.css?ver=e3f3251c4937f8ec7d691e758a7a5a12' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/11.0/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/6.0/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://southfloridareporter.com/wp-content/themes/Newsmag-child/custom.js?ver=6.0' id='custom-script-js'></script>
<link rel="https://api.w.org/" href="https://southfloridareporter.com/wp-json/" /><link rel="alternate" type="application/json" href="https://southfloridareporter.com/wp-json/wp/v2/posts/102397" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://southfloridareporter.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://southfloridareporter.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0" />
<link rel='shortlink' href='https://southfloridareporter.com/?p=102397' />
<link rel="alternate" type="application/json+oembed" href="https://southfloridareporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsouthfloridareporter.com%2F3-everyday-retail-stocks-yielding-over-3%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://southfloridareporter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsouthfloridareporter.com%2F3-everyday-retail-stocks-yielding-over-3%2F&#038;format=xml" />
<style>img#wpstats{display:none}</style>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/southfloridareporter.com\/wp-admin\/","wpRestNonce":"f39f9010d7","wpRestUrl":"https:\/\/southfloridareporter.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>

<script>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</script>

<script src="https://cdn.adapex.io/hb/aaw.sfr.js" asyns></script>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-9585758-36', 'auto');
  ga('send', 'pageview');

</script>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://southfloridareporter.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://southfloridareporter.com/consumer/",
                    "name": "Consumer"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/",
                    "name": "3 Everyday Retail Stocks Yielding Over 3%"                                
                }
            }    
        ]
    }
</script>
<style type="text/css" id="wp-custom-css">
			.greenMenuCover{
	display: none;
}

/* Popup form */

.tnp-subscription input[type=submit]:hover {
background-color: #2c9138;
}

.tnp-subscription input[type=submit] {
  background-color: #00B5E2;
}

.tnp-subscription input[type=submit] {
  color: #ffffff;
}

.tnp-subscription input[type=submit] {
  font-weight: bold;;
}

.tnp-subscription input[type=submit] {
  font-size: 20px;;
}

.tnp-modal h1{
	font-size: 28px!important;
    color: #1a78d7!important;
}
.tnp-popup-main .tnp-field-email label{
	color: #000;
}
.tnp-popup-main{
	width: 100%;
}
.tnp-popup-pre, .tnp-popup-post{
	font-size: 14px!important;
  color: #000!important;
	font-weight:300;
}

#tnp-leads-topbar {
    display: none;
}

.tnp-modal {
    padding: 0px 20px 10px 20px;	
}


#simplemodal-container input.tnp-submit {
    text-shadow: 0 0 2px #000;
		text-transform: unset;
		font-size: 18px;
		font-weight: 700;
		letter-spacing: 2px;
}
/* end of Popup form */		</style>
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript> <style id="tdw-css-placeholder"></style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script async src='/cdn-cgi/challenge-platform/h/b/scripts/invisible.js?ts=1656460800'></script></head>
<body class="post-template-default single single-post postid-102397 single-format-standard 3-everyday-retail-stocks-yielding-over-3 global-block-template-1 wpb-js-composer js-comp-ver-6.9.0 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/southfloridareporter?fref=ts" title="Facebook" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SFlReporter" title="Twitter" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-14" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-14"><a href="https://southfloridareporter.com/" data-wpel-link="internal">HOME</a></li>
<li id="menu-item-21620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-21620"><a href="https://southfloridareporter.com/news/" data-wpel-link="internal">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-67661" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67661"><a href="https://southfloridareporter.com/coronavirus/" data-wpel-link="internal">Coronavirus</a></li>
<li id="menu-item-21618" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21618"><a href="https://southfloridareporter.com/zzz/crime/" data-wpel-link="internal">Crime</a></li>
<li id="menu-item-21617" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21617"><a href="https://southfloridareporter.com/environmental/" data-wpel-link="internal">Environmental</a></li>
<li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109"><a href="https://southfloridareporter.com/health/" data-wpel-link="internal">Health</a></li>
<li id="menu-item-55532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55532"><a href="https://southfloridareporter.com/politics/" data-wpel-link="internal">Politics</a></li>
</ul>
</li>
<li id="menu-item-26380" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26380"><a href="https://southfloridareporter.com/testdrivenow/" data-wpel-link="internal">Car Reviews</a></li>
<li id="menu-item-246" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-246"><a href="https://southfloridareporter.com/consumer/" data-wpel-link="internal">Consumer<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-75438" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75438"><a href="https://southfloridareporter.com/attractions/" data-wpel-link="internal">Attractions</a></li>
<li id="menu-item-29950" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29950"><a href="https://southfloridareporter.com/zzz/sections-2/drones/" data-wpel-link="internal">Drones</a></li>
<li id="menu-item-54993" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54993"><a href="https://southfloridareporter.com/education-2/" data-wpel-link="internal">Education</a></li>
<li id="menu-item-75543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75543"><a href="https://southfloridareporter.com/entertainment/" data-wpel-link="internal">Entertainment</a></li>
<li id="menu-item-75544" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75544"><a href="https://southfloridareporter.com/gambling/" data-wpel-link="internal">Gambling</a></li>
<li id="menu-item-22844" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22844"><a href="https://southfloridareporter.com/people/" data-wpel-link="internal">People</a></li>
<li id="menu-item-69515" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69515"><a href="https://southfloridareporter.com/dining/" data-wpel-link="internal">Restaurants</a></li>
<li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110"><a href="https://southfloridareporter.com/space/" data-wpel-link="internal">Space</a></li>
<li id="menu-item-115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115"><a href="https://southfloridareporter.com/technology/" data-wpel-link="internal">Tech</a></li>
<li id="menu-item-75546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75546"><a href="https://southfloridareporter.com/zzz/theater/" data-wpel-link="internal">Theater</a></li>
</ul>
</li>
<li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://southfloridareporter.com/food/" data-wpel-link="internal">Food Reviews</a></li>
<li id="menu-item-27161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27161"><a href="https://southfloridareporter.com/today-is/" data-wpel-link="internal">Today Is</a></li>
<li id="menu-item-55393" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55393"><a href="https://southfloridareporter.com/video/" data-wpel-link="internal">Video</a></li>
<li id="menu-item-55379" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55379"><a href="https://southfloridareporter.com/wine-review/" data-wpel-link="internal">Wine Reviews</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://southfloridareporter.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap">
<div class="td-outer-container">

<div class="td-header-container td-header-wrap td-header-style-1">
<div class="td-header-row td-header-top-menu">
<div class="td-top-bar-container top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-21606" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-21606"><a href="https://southfloridareporter.com/who-we-are/" data-wpel-link="internal">Who We Are</a></li>
<li id="menu-item-21607" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-21607"><a href="https://southfloridareporter.com/our-contributing-partners/" data-wpel-link="internal">Our Partners</a></li>
<li id="menu-item-21605" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-21605"><a href="https://southfloridareporter.com/td_d_slug_15/" data-wpel-link="internal">Contact Us</a></li>
</ul></div></div> <div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/southfloridareporter?fref=ts" title="Facebook" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SFlReporter" title="Twitter" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span> </div>
</div>

</div>
<div class="td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://southfloridareporter.com/" data-wpel-link="internal">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/06/17014213/sfreproter1.png" /><noscript><img src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/06/17014213/sfreproter1.png" alt=""/></noscript>
<span class="td-visual-hidden">South Florida Reporter</span>
</a>
</div>
<div class="td-header-sp-rec">
<div class="td-header-ad-wrap  td-ad-m td-ad-tp">
<div class="td-a-rec td-a-rec-id-header  td-rec-hide-on-p td_uid_1_62bbbdec20eb1_rand td_block_template_1">





<a href="https://www.vanhornlawgroup.com/covid-19-impact-on-south-florida" target="_blank" onclick="ga(&#039;send&#039;, &#039;event&#039;, { eventCategory: &#039;Covid19 - Van Horn Law Group, P.A.&#039;, eventAction: &#039;click&#039;, eventLabel: &#039;HeaderVanHornLawGroupAd&#039; }); " data-wpel-link="external" rel="nofollow external noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20728%2090'%3E%3C/svg%3E" alt="Van Horn Law Group, P.A. - Losing Your Home? " title="Van Horn Law Group, P.A. - Losing Your Home? " width="728" height="90" data-lazy-src="https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2021/07/15124144/Foreclosure-Banner-Ad-VanHorn-scaled.jpg" /><noscript><img src="https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2021/07/15124144/Foreclosure-Banner-Ad-VanHorn-scaled.jpg" alt="Van Horn Law Group, P.A. - Losing Your Home? " title="Van Horn Law Group, P.A. - Losing Your Home? " width="728" height="90" /></noscript></a></div>
</div> </div>
</div>
<div class="td-header-menu-wrap">
<div class="td-header-row td-header-border td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-mobile" href="https://southfloridareporter.com/" data-wpel-link="internal">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://southfloridareporter.com/wp-content/uploads/2015/06/master-logo.jpg" /><noscript><img src="https://southfloridareporter.com/wp-content/uploads/2015/06/master-logo.jpg" alt=""/></noscript>
</a>
<a class="td-header-logo td-sticky-mobile" href="https://southfloridareporter.com/" data-wpel-link="internal">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/06/17014213/sfreproter1.png" /><noscript><img src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/06/17014213/sfreproter1.png" alt=""/></noscript>
</a>
</div>
<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-14"><a href="https://southfloridareporter.com/" data-wpel-link="internal">HOME</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-21620"><a href="https://southfloridareporter.com/news/" data-wpel-link="internal">News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-67661"><a href="https://southfloridareporter.com/coronavirus/" data-wpel-link="internal">Coronavirus</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-21618"><a href="https://southfloridareporter.com/zzz/crime/" data-wpel-link="internal">Crime</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-21617"><a href="https://southfloridareporter.com/environmental/" data-wpel-link="internal">Environmental</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-109"><a href="https://southfloridareporter.com/health/" data-wpel-link="internal">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-55532"><a href="https://southfloridareporter.com/politics/" data-wpel-link="internal">Politics</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-26380"><a href="https://southfloridareporter.com/testdrivenow/" data-wpel-link="internal">Car Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-246"><a href="https://southfloridareporter.com/consumer/" data-wpel-link="internal">Consumer</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-75438"><a href="https://southfloridareporter.com/attractions/" data-wpel-link="internal">Attractions</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-29950"><a href="https://southfloridareporter.com/zzz/sections-2/drones/" data-wpel-link="internal">Drones</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-54993"><a href="https://southfloridareporter.com/education-2/" data-wpel-link="internal">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-75543"><a href="https://southfloridareporter.com/entertainment/" data-wpel-link="internal">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-75544"><a href="https://southfloridareporter.com/gambling/" data-wpel-link="internal">Gambling</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-22844"><a href="https://southfloridareporter.com/people/" data-wpel-link="internal">People</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-69515"><a href="https://southfloridareporter.com/dining/" data-wpel-link="internal">Restaurants</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-110"><a href="https://southfloridareporter.com/space/" data-wpel-link="internal">Space</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-115"><a href="https://southfloridareporter.com/technology/" data-wpel-link="internal">Tech</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-75546"><a href="https://southfloridareporter.com/zzz/theater/" data-wpel-link="internal">Theater</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-111"><a href="https://southfloridareporter.com/food/" data-wpel-link="internal">Food Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-27161"><a href="https://southfloridareporter.com/today-is/" data-wpel-link="internal">Today Is</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-55393"><a href="https://southfloridareporter.com/video/" data-wpel-link="internal">Video</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-55379"><a href="https://southfloridareporter.com/wine-review/" data-wpel-link="internal">Wine Reviews</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://southfloridareporter.com/">
<div role="search" class="td-head-form-search-wrap">
<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
</div>
</div>
<div class="td-container td-post-template-default">
<div class="td-container-border">
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-102397" class="post-102397 post type-post status-publish format-standard has-post-thumbnail hentry category-consumer category-featured category-financial category-rick-orford tag-sflreporter tag-swflreporter tag-rickorford tag-sflr-2 tag-southfloridareporter-com-2 tag-swfloridareporter-com-2 tag-swflr-2" itemscope itemtype="https://schema.org/Article" 47>
<div class="td-post-header td-pb-padding-side">
<div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://southfloridareporter.com/" data-wpel-link="internal">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Consumer" class="entry-crumb" href="https://southfloridareporter.com/consumer/" data-wpel-link="internal">Consumer</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">3 Everyday Retail Stocks Yielding Over 3%</span></div>

<header>
<h1 class="entry-title">3 Everyday Retail Stocks Yielding Over 3%</h1>
<div class="meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://southfloridareporter.com/author/rick-orford/" data-wpel-link="internal">Rick Orford</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-28T19:40:10+00:00">Jun 28, 2022</time></span>    </div>
</header>
</div>
<div class="td-post-sharing-top td-pb-padding-side"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fsouthfloridareporter.com%2F3-everyday-retail-stocks-yielding-over-3%2F" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=3+Everyday+Retail+Stocks+Yielding+Over+3%25&amp;url=https%3A%2F%2Fsouthfloridareporter.com%2F3-everyday-retail-stocks-yielding-over-3%2F&amp;via=SFlReporter" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/&amp;media=https://southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg&amp;description=Like most stocks those of retailers are also down - except for these three. You may want to check them out." data-wpel-link="external" rel="nofollow external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=3+Everyday+Retail+Stocks+Yielding+Over+3%25 %0A%0A https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/" data-wpel-link="internal">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/&amp;title=3+Everyday+Retail+Stocks+Yielding+Over+3%25" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
<div class="td-social-but-text">Linkedin</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/&amp;title=3+Everyday+Retail+Stocks+Yielding+Over+3%25" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content td-pb-padding-side">
<div class="td-post-featured-image"><img width="635" height="450" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20635%20450'%3E%3C/svg%3E" data-lazy-srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg?w=635&ssl=1 635w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg?resize=300%2C213&ssl=1 300w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg?resize=593%2C420&ssl=1 593w" data-lazy-sizes="(max-width: 635px) 100vw, 635px" alt="" title="2642363" data-lazy-src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg?resize=635%2C450&ssl=1" /><noscript><img width="635" height="450" class="entry-thumb" src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg?resize=635%2C450&ssl=1" srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg?w=635&ssl=1 635w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg?resize=300%2C213&ssl=1 300w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg?resize=593%2C420&ssl=1 593w" sizes="(max-width: 635px) 100vw, 635px" alt="" title="2642363"/></noscript></div>
<div id="td_uid_1_62bbbdec239f0" class="tdc-row"><div class="vc_row td_uid_2_62bbbdec239f4_rand  wpb_row td-pb-row">
<style scoped>

/* custom css */
.td_uid_2_62bbbdec239f4_rand {
                    min-height: 0;
                }
</style><div class="vc_column td_uid_3_62bbbdec23ac1_rand  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.td_uid_3_62bbbdec23ac1_rand {
                    vertical-align: baseline;
                }
</style><div class="wpb_wrapper"><div class="wpb_wrapper wpb_text_column td_block_wrap td_block_wrap vc_column_text td_uid_4_62bbbdec23b5a_rand  td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_4_62bbbdec23b5a"><div class="td-block-title-wrap"></div><div class="td-fix-index"><div class='code-block code-block-3' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>
<div data-aaad='true' data-aa-adunit='/22181265/sfr_mob_300v_1'></div></div>
<p><em><strong><a href="https://www.dividendpower.org/2022/03/15/3-everyday-retail-stocks-yielding-over-3/" data-wpel-link="exclude"><img class="alignleft wp-image-102398 jetpack-lazy-image" src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/Dividend-Power.jpg?resize=140%2C28&#038;ssl=1" alt width="140" height="28" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/Dividend-Power.jpg?w=250&amp;ssl=1 250w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/Dividend-Power.jpg?resize=238%2C50&amp;ssl=1 238w" data-lazy-sizes="(max-width: 140px) 100vw, 140px" data-lazy-src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/Dividend-Power.jpg?resize=140%2C28&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignleft wp-image-102398" src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/Dividend-Power.jpg?resize=140%2C28&#038;ssl=1" alt="" width="140" height="28" srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/Dividend-Power.jpg?w=250&amp;ssl=1 250w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/Dividend-Power.jpg?resize=238%2C50&amp;ssl=1 238w" sizes="(max-width: 140px) 100vw, 140px" data-recalc-dims="1" /></noscript></a>By <span class="posted-by vcard author"><a class="url fn n" title="View all posts by Dividend Power" href="https://rickorford.com/author/dividendpower/" rel="author" data-wpel-link="exclude"><span class="author-name">Dividend Power</span> </a></span></strong></em></p><div class='code-block code-block-9' style='margin: 8px 0; clear: both;'>
<div style="width:100%; overflow:hidden;">
<div style="width: 50%; float: left; padding: 5px;" data-aaad='true' data-aa-adunit='/22181265/sfr_300s_1'></div>
<div style="width: 50%; float: left; padding: 5px;" data-aaad='true' data-aa-adunit='/22181265/sfr_300s_2'></div>
</div></div>
<div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<div data-aaad='true' data-aa-adunit='/22181265/sfr_mob_300v_2'></div></div>
<p>Retail stocks are down along with the rest of the stock market. The SPDR S&amp;P Retail ETF (XRT) has declined approximately (-32%) year-to-date (YTD). Some retail stocks are down even more. Many retail stocks benefitted during the COVID-19 pandemic as consumers spent their savings and Federal stimulus dollars online. However, the tailwinds are subsiding and turning into headwinds as retailers are lapping tough comparisons from 2021 and the global economy slows.</p><div class='code-block code-block-12' style='margin: 8px 0; clear: both;'>
<div class='s2nPlayer k-Wor1EHln' data-type='float'></div>
<script type='text/javascript' src='//embed.sendtonews.com/player3/embedcode.js?fk=Wor1EHln&cid=11808&offsetx=0&offsety=0&floatwidth=400&floatposition=bottom-right' data-type='s2nScript'></script></div>
<p>Some retail stocks have struggled with the move to e-commerce and a large brick-and-mortar footprint. Furthermore, competition from Amazon (AMZN) and other online retailers was intense. However, the pandemic and competition forced many companies to adapt and innovate.</p>
<p>Three everyday retail stocks for investors to consider for their portfolios are Best Buy Co. (NYSE: BBY), Walgreens Boots Alliance (NASDAQ: WBA), and Restaurant Brands International (NYSE: QSR). Besides the solid <a href="https://www.dividendpower.org/2021/10/26/what-is-a-dividend/" data-wpel-link="exclude"><strong>dividend yields</strong></a>, all three stocks are dividend growth stocks with 10+ years of dividend growth.</p><div class="td-a-rec td-a-rec-id-content_inline  td_uid_7_62bbbdec250dc_rand td_block_template_1"><div class="articleMiddleContent">
<div class="adLeft"><div data-aaad='true' data-aa-adunit='/22181265/sfr_300s_1'></div></div>
<div class="adLeft"><div data-aaad='true' data-aa-adunit='/22181265/sfr_300s_2'></div></div>
</div>
<style>.articleMiddleContent{ text-align:center; overflow:hidden;}
.adLeft{ padding:5px; width:50%; float:left;}</style></div>
<h4 id="h-3-everyday-retail-stocks-yielding-over-3"><span id="3_Everyday_Retail_Stocks_Yielding_Over_3"><strong>3 Everyday Retail Stocks Yielding Over 3%</strong></span></h4>
<h5 id="h-best-buy-a-survivor"><span id="Best_Buy_A_Survivor"><strong>Best Buy – A Survivor</strong></span></h5>
<p>Best Buy is one of the largest pure-play electronics and appliance retailers in North America. The company is a survivor, having outlasted many of its brick-and-mortar competitors. Consumers may remember chains such as Circuit City, Radio Shack, Fry’s, H.H. Gregg, CompUSA, Tweeter, Crazy Eddie’s, and others. Today, Best Buy is a giant with 930+ stores in the US and another 120+ stores in Canada.</p>
<p>Best Buy struggled for several years between 2012 and 2017 with declining or low comparable sales. However, the retailer’s fortunes improved since 2018 as the company reduced store counts and moved more sales online. Furthermore, the pandemic drove sales of electronics. As a result, total revenue reached more than $51 billion in fiscal 2021.</p>
<p>Today, Best Buy is well-positioned to sell consumers mobile phones, TVs, appliances, computers, printers, and other items. In addition, Best Buy has the Geek Squad and the new total tech membership, which should help drives sales and services.</p>
<p>Best Buy is a dividend stock. The forward dividend yield is now 4.94%. The dividend is supported by a conservative payout ratio of about 30% and over $2,500 million in free cash flow (FCF). In addition, best Buy has a solid balance sheet with more cash than long-term debt adding to the dividend safety.</p>
<p>Best Buy’s last quarterly dividend increase was ~25.7% to $0.88 per share from $0.70 per share. The dividend growth rate was about 20% CAGR in the past 5-years. Best Buy has raised the dividend for 19 consecutive years, and the relatively low payout ratio supports future growth. The forward price-to-earnings (P/E) ratio of 8.3X is below the average in the past 5-years.</p>
<ul>
<li>Ticker: BBY</li>
<li>Market Cap: $15.87 billion</li>
<li>Annual Dividend Rate (FWD): $3.52</li>
<li>Dividend Yield: 4.94%</li>
</ul>
<figure class="wp-block-embed is-type-wp-embed is-provider-rick-orford-invest-earn-more-income-amp-save-money wp-block-embed-rick-orford-invest-earn-more-income-amp-save-money">
<div class="wp-block-embed__wrapper"><iframe loading="lazy" class="wp-embedded-content" title="“Best International ETF – Our Top 10 to Consider in 2022” — Rick Orford - Invest, Earn More Income &amp; Save Money" src="about:blank" width="600" height="599" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" sandbox="allow-scripts" data-secret="sh8Sa7pxRt" data-mce-fragment="1" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://rickorford.com/best-international-etf/embed/#?secret=TZiiqV96Wa#?secret=sh8Sa7pxRt"></iframe><noscript><iframe class="wp-embedded-content" title="“Best International ETF – Our Top 10 to Consider in 2022” — Rick Orford - Invest, Earn More Income &amp; Save Money" src="https://rickorford.com/best-international-etf/embed/#?secret=TZiiqV96Wa#?secret=sh8Sa7pxRt" width="600" height="599" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" sandbox="allow-scripts" data-secret="sh8Sa7pxRt" data-mce-fragment="1"></iframe></noscript></div>
</figure>
<h5 id="h-walgreens-boots-alliance-a-dividend-aristocrat"><span id="Walgreens_Boots_Alliance_A_Dividend_Aristocrat"><strong>Walgreens Boots Alliance – A Dividend Aristocrat</strong></span></h5>
<p>Walgreens Boots is one of the largest pharmacy retail chains in the US and UK, with over 13,000 locations. The company operates roughly 9,000 Walgreens stores in the US and 4,000 Boots stores in the UK, and stores in other locations for nine total countries. Major brands include Walgreens, Boots, Duane Reade, the No7 Beauty Company, Benavides, and Ahumada. Total sales were $132+ billion in the fiscal year 2021.</p>
<p>Walgreens’ stock price has been on a downward trend since 2015 after Walgreens merged with Boots. The retail giant struggled with merger integration and operational execution challenges. For perspective, the stock price traded at more than $96 per share in 2015 and bottomed at below $35 per share in 2020. The current stock price is ~$40.89.</p>
<p>Walgreens now has a new CEO who is divesting Boots, undoing the merger. The company is <a href="https://www.reuters.com/business/healthcare-pharmaceuticals/boots-store-10-bln-sale-bid-deadline-looms-2022-02-23/" data-wpel-link="exclude">selling</a> the Boots chain and has asked bidders to submit first-round bids. Reportedly, several private equity firms are submitting bids. In addition, the new CEO is partnering with VillageMD to open collocated primary care offices and pharmacies. This new strategy focuses on providing healthcare and retail in one location.</p>
<p>Walgreens Boots’ forward dividend yield is ~4.67%. The company is known for its many years of dividend growth. The pharmacy retailer has increased the dividend for 47 years, and the stock is a <a href="https://www.dividendpower.org/2022/03/04/the-list-of-dividend-aristocrats-2022/" data-wpel-link="exclude"><strong>Dividend Aristocrat</strong></a>. The dividend growth rate (CAGR) is slowing, but it is still respectable at ~9.0% in the past decade, approximately 5.2% in the past 5-years, and around 4.0% in the trailing 3-years.</p>
<p>In addition, the payout ratio is very conservative at ~36%, leaving room for future increases. This value also provides confidence about dividend safety. Walgreens Boots is trading below the average market valuation with a low earnings multiple of ~8.1X.</p>
<ul>
<li>Ticker: WBA</li>
<li>Market Cap: $34.64 billion</li>
<li>Annual Dividend Rate (FWD): $1.91</li>
<li>Dividend Yield: 4.67%</li>
</ul>
<figure class="wp-block-embed is-type-wp-embed is-provider-rick-orford-invest-earn-more-income-amp-save-money wp-block-embed-rick-orford-invest-earn-more-income-amp-save-money">
<div class="wp-block-embed__wrapper"><iframe loading="lazy" class="wp-embedded-content" title="“How To Invest In Dividend Stocks For Income” — Rick Orford - Invest, Earn More Income &amp; Save Money" src="about:blank" width="600" height="591" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" sandbox="allow-scripts" data-secret="1wUmKcFEFR" data-mce-fragment="1" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://rickorford.com/how-to-invest-in-dividend-stocks-for-income/embed/#?secret=rbjqQrOJVp#?secret=1wUmKcFEFR"></iframe><noscript><iframe class="wp-embedded-content" title="“How To Invest In Dividend Stocks For Income” — Rick Orford - Invest, Earn More Income &amp; Save Money" src="https://rickorford.com/how-to-invest-in-dividend-stocks-for-income/embed/#?secret=rbjqQrOJVp#?secret=1wUmKcFEFR" width="600" height="591" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" sandbox="allow-scripts" data-secret="1wUmKcFEFR" data-mce-fragment="1"></iframe></noscript></div>
</figure>
<h5 id="h-restaurant-brands-international-little-known"><span id="Restaurant_Brands_International_Little_Known"><strong>Restaurant Brands International – Little Known</strong></span></h5>
<p>Restaurant Brands International is a consolidator of fast-food retail chains. The company now owns the Tim Hortons, Burger King, Popeyes Louisiana Kitchen, and Firehouse Subs brands. The total store count is about 29,000 located in 100 countries. The company is controlled by a private equity firm, 3G Capital. Total system sales were $35+ billion, and revenue was about $5.74 billion in 2021.</p><div class='code-block code-block-5' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>
<div data-aaad='true' data-aa-adunit='/22181265/sfr_mob_300v_3'></div></div>
<p>The stock price has fallen since its recent high in mid-2001 and is trading near a 52-week low. Several of the brands are experiencing slow recoveries or are in a middle of a turnaround. In addition, the fast-food business is very competitive. However, the company increases its store count and revenue by franchising its four brands with partners and has done so successfully.</p>
<p>The dividend yield is about 4.44%. However, the payout ratio is high at about 75%. Still, Restaurant Brands increased the dividend even during the COVID-19 pandemic and has reached the 10-year mark making the stock a <a href="https://www.dividendpower.org/2022/02/04/the-list-of-dividend-contenders-2022/" data-wpel-link="exclude"><strong>Dividend Contender</strong></a>. The dividend growth rate was about 27.9% in the past 5-years but has slowed down recently. Future increases may be muted. The stock’s price-to-earnings (P/E) ratio has come down to about 16.4X and is near the lower end of its range in the past decade.</p>
<ul>
<li>Ticker: QSR</li>
<li>Market Cap: $21.69 billion</li>
<li>Annual Dividend Rate (FWD): $2.16</li>
<li>Dividend Yield: 4.44%</li>
</ul>
<p><strong>Related Articles by Dividend Power</strong></p>
<ul>
<li><a href="https://www.dividendpower.org/2021/09/30/how-to-live-off-dividends/" data-wpel-link="exclude"><strong>How to Live Off Dividends</strong></a></li>
<li><a href="https://www.dividendpower.org/2021/08/10/when-to-sell-a-dividend-stock/" data-wpel-link="exclude"><strong>When to Sell a Dividend Stock</strong></a></li>
</ul>
<p><em>Disclosure: None.</em></p>
<p><span class="td_btn td_btn_md td_outlined_btn" style="color: #000000;"><strong><em>Disclaimer:</em></strong><em> The author is not a licensed or registered investment adviser or broker/dealer. He is not providing you with individual investment advice. Please consult with a licensed investment professional before you invest your money. </em></span></p>
</div></div></div></div></div></div><div id="td_uid_3_62bbbdec24642" class="tdc-row"><div class="vc_row td_uid_5_62bbbdec24645_rand  wpb_row td-pb-row">
<style scoped>

/* custom css */
.td_uid_5_62bbbdec24645_rand {
                    min-height: 0;
                }
</style><div class="vc_column td_uid_6_62bbbdec246d6_rand  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.td_uid_6_62bbbdec246d6_rand {
                    vertical-align: baseline;
                }
</style><div class="wpb_wrapper"><div class="vc_message_box vc_message_box-standard vc_message_box-rounded vc_color-blue"><div class="vc_message_box-icon"><i class="fas fa-info-circle"></i></div><p><strong>This article originally appeared on </strong><a href="https://rickorford.com/3-everyday-retail-stocks-yielding-over-3/" data-wpel-link="exclude"><strong>Rick </strong><strong><u>Orford</u></strong></a><strong>. </strong></p>
<p><strong>Republished with permission by </strong><a href="http://www.southfloridareporter.com/" data-wpel-link="internal"><strong>SouthFloridaReporter.com</strong></a><strong> on June 28, 2022</strong></p>
</div></div></div></div></div>


<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_bottom td_uid_8_62bbbdec2518d_rand td_block_template_1">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1024 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-3799504456100090" data-ad-slot="9762988162"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
                    if ( td_screen_width >= 768  && td_screen_width < 1024 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-3799504456100090" data-ad-slot="9762988162"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-3799504456100090" data-ad-slot="9762988162"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

</div>
<footer>
 
<div class="td-post-source-tags td-pb-padding-side">
  </div>
<div class="td-post-sharing-bottom td-pb-padding-side"><div class="td-post-sharing-classic"><iframe loading="lazy" frameBorder="0" src="about:blank" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://www.facebook.com/plugins/like.php?href=https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/&#038;layout=button_count&#038;show_faces=false&#038;width=105&#038;action=like&#038;colorscheme=light&#038;height=21"></iframe><noscript><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></noscript></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fsouthfloridareporter.com%2F3-everyday-retail-stocks-yielding-over-3%2F" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=3+Everyday+Retail+Stocks+Yielding+Over+3%25&amp;url=https%3A%2F%2Fsouthfloridareporter.com%2F3-everyday-retail-stocks-yielding-over-3%2F&amp;via=SFlReporter" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/&amp;media=https://southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg&amp;description=Like most stocks those of retailers are also down - except for these three. You may want to check them out." data-wpel-link="external" rel="nofollow external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=3+Everyday+Retail+Stocks+Yielding+Over+3%25 %0A%0A https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/" data-wpel-link="internal">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/&amp;title=3+Everyday+Retail+Stocks+Yielding+Over+3%25" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
<div class="td-social-but-text">Linkedin</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/&amp;title=3+Everyday+Retail+Stocks+Yielding+Over+3%25" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>  <div class="author-box-wrap"><a href="https://southfloridareporter.com/author/rick-orford/" data-wpel-link="internal"><img src="https://www.gravatar.com/avatar.php?gravatar_id=500423fb880eb57cb36c946a36127734&amp;size=40" height="64" width="64" data-lazy-src="https://www.gravatar.com/avatar.php?gravatar_id=500423fb880eb57cb36c946a36127734&amp;size=40&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src='https://www.gravatar.com/avatar.php?gravatar_id=500423fb880eb57cb36c946a36127734&size=40' height='64' width='64' alt=rick@rickorford.com' /></noscript></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://southfloridareporter.com/author/rick-orford/" data-wpel-link="internal">Rick Orford</a></span></div><div class="td-author-url"><a href="https://thefinanciallyindependentmillennial.com/how-to-generate-income-from-a-portfolio/" data-wpel-link="external" rel="nofollow external noopener noreferrer">https://thefinanciallyindependentmillennial.com/how-to-generate-income-from-a-portfolio/</a></div><div class="td-author-description">Rick is an author and finance writer. His work has appeared in several high-ranking media placements, including Good Morning America, Washington Post, Yahoo Finance, NBC, FOX, CBS, and ABC News. He is known as a respected, influential business leader that brings a proven ability to translate vision into reality. When not writing about finance, Rick enjoys writing about his other passion, travel.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Rick Orford"></span><meta itemprop="datePublished" content="2022-06-28T19:40:10+00:00"><meta itemprop="dateModified" content="2022-06-28T19:21:26-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://southfloridareporter.com/3-everyday-retail-stocks-yielding-over-3/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/06/17014213/sfreproter1.png"></span><meta itemprop="name" content="South Florida Reporter"></span><meta itemprop="headline " content="3 Everyday Retail Stocks Yielding Over 3%"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/2642363.jpg?fit=635%2C450&ssl=1"><meta itemprop="width" content="635"><meta itemprop="height" content="450"></span> </footer>
</article> 
<script>var block_td_uid_9_62bbbdec25c0a = new tdBlock();
block_td_uid_9_62bbbdec25c0a.id = "td_uid_9_62bbbdec25c0a";
block_td_uid_9_62bbbdec25c0a.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_9_62bbbdec25c0a_rand","td_column_number":3,"live_filter_cur_post_id":102397,"live_filter_cur_post_author":"251","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_9_62bbbdec25c0a_rand","tdc_css_class_style":"td_uid_9_62bbbdec25c0a_rand_style"}';
block_td_uid_9_62bbbdec25c0a.td_column_number = "3";
block_td_uid_9_62bbbdec25c0a.block_type = "td_block_related_posts";
block_td_uid_9_62bbbdec25c0a.post_count = "6";
block_td_uid_9_62bbbdec25c0a.found_posts = "16136";
block_td_uid_9_62bbbdec25c0a.header_color = "";
block_td_uid_9_62bbbdec25c0a.ajax_pagination_infinite_stop = "";
block_td_uid_9_62bbbdec25c0a.max_num_pages = "2690";
tdBlocksArray.push(block_td_uid_9_62bbbdec25c0a);
</script><div class="td_block_wrap td_block_related_posts td_uid_9_62bbbdec25c0a_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_9_62bbbdec25c0a"><h4 class="td-related-title"><a id="td_uid_10_62bbbdec2f69c" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_9_62bbbdec25c0a" href="#">RELATED ARTICLES</a><a id="td_uid_11_62bbbdec2f6a0" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_9_62bbbdec25c0a" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_9_62bbbdec25c0a class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://southfloridareporter.com/from-under-to-on-the-rocks-invasive-crabs-become-whiskey/" rel="bookmark" class="td-image-wrap" title="From Under To On The Rocks: Invasive Crabs Become Whiskey" data-wpel-link="internal"><img width="238" height="178" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20238%20178'%3E%3C/svg%3E" data-lazy-srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?zoom=2&resize=238%2C178&ssl=1 476w" data-lazy-sizes="(max-width: 238px) 100vw, 238px" alt="" title="From Under To On The Rocks: Invasive Crabs Become Whiskey" data-lazy-src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=238%2C178&ssl=1" /><noscript><img width="238" height="178" class="entry-thumb" src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=238%2C178&ssl=1"  srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?zoom=2&resize=238%2C178&ssl=1 476w" sizes="(max-width: 238px) 100vw, 238px"  alt="" title="From Under To On The Rocks: Invasive Crabs Become Whiskey" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://southfloridareporter.com/from-under-to-on-the-rocks-invasive-crabs-become-whiskey/" rel="bookmark" title="From Under To On The Rocks: Invasive Crabs Become Whiskey" data-wpel-link="internal">From Under To On The Rocks: Invasive Crabs Become Whiskey</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://southfloridareporter.com/undetected-high-cholesterol-found-in-2-out-of-3-stroke-patients/" rel="bookmark" class="td-image-wrap" title="Undetected High Cholesterol Found In 2 Out Of 3 Stroke Patients" data-wpel-link="internal"><img width="238" height="178" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20238%20178'%3E%3C/svg%3E" data-lazy-srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?zoom=2&resize=238%2C178&ssl=1 476w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?zoom=3&resize=238%2C178&ssl=1 714w" data-lazy-sizes="(max-width: 238px) 100vw, 238px" alt="https://www.vecteezy.com/photo/4623178-visit-to-cardiologist" title="Undetected High Cholesterol Found In 2 Out Of 3 Stroke Patients" data-lazy-src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=238%2C178&ssl=1" /><noscript><img width="238" height="178" class="entry-thumb" src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=238%2C178&ssl=1"  srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?zoom=2&resize=238%2C178&ssl=1 476w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?zoom=3&resize=238%2C178&ssl=1 714w" sizes="(max-width: 238px) 100vw, 238px"  alt="https://www.vecteezy.com/photo/4623178-visit-to-cardiologist" title="Undetected High Cholesterol Found In 2 Out Of 3 Stroke Patients" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://southfloridareporter.com/undetected-high-cholesterol-found-in-2-out-of-3-stroke-patients/" rel="bookmark" title="Undetected High Cholesterol Found In 2 Out Of 3 Stroke Patients" data-wpel-link="internal">Undetected High Cholesterol Found In 2 Out Of 3 Stroke Patients</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://southfloridareporter.com/how-hearing-affects-your-brain-health-video/" rel="bookmark" class="td-image-wrap" title="How Hearing Affects Your Brain Health (Video)" data-wpel-link="internal"><img width="238" height="178" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20238%20178'%3E%3C/svg%3E" data-lazy-srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?zoom=2&resize=238%2C178&ssl=1 476w" data-lazy-sizes="(max-width: 238px) 100vw, 238px" alt="" title="How Hearing Affects Your Brain Health (Video)" data-lazy-src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?resize=238%2C178&ssl=1" /><noscript><img width="238" height="178" class="entry-thumb" src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?resize=238%2C178&ssl=1"  srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_hearing-aid_833205.jpg?zoom=2&resize=238%2C178&ssl=1 476w" sizes="(max-width: 238px) 100vw, 238px"  alt="" title="How Hearing Affects Your Brain Health (Video)" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://southfloridareporter.com/how-hearing-affects-your-brain-health-video/" rel="bookmark" title="How Hearing Affects Your Brain Health (Video)" data-wpel-link="internal">How Hearing Affects Your Brain Health (Video)</a></h3> </div>
</div>
</div> </div>
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://southfloridareporter.com/investing-in-alzheimers-research-in-2022/" rel="bookmark" class="td-image-wrap" title="Investing In Alzheimer’s Research In 2022" data-wpel-link="internal"><img width="238" height="178" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20238%20178'%3E%3C/svg%3E" data-lazy-srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?zoom=2&resize=238%2C178&ssl=1 476w" data-lazy-sizes="(max-width: 238px) 100vw, 238px" alt="https://www.vecteezy.com/photo/7669559-scientist-looking-through-scientific-microscope-lense-in-laboratory-scientist-doing-research-in-term-of-medicine-biotechnology-biology-or-chemistry-doctor-analyzing-work-in-medical-microbiology-lab" title="Investing In Alzheimer’s Research In 2022" data-lazy-src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?resize=238%2C178&ssl=1" /><noscript><img width="238" height="178" class="entry-thumb" src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?resize=238%2C178&ssl=1"  srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_scientist-looking-through-scientific-microscope-lense-in_7669559_918.jpg?zoom=2&resize=238%2C178&ssl=1 476w" sizes="(max-width: 238px) 100vw, 238px"  alt="https://www.vecteezy.com/photo/7669559-scientist-looking-through-scientific-microscope-lense-in-laboratory-scientist-doing-research-in-term-of-medicine-biotechnology-biology-or-chemistry-doctor-analyzing-work-in-medical-microbiology-lab" title="Investing In Alzheimer’s Research In 2022" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://southfloridareporter.com/investing-in-alzheimers-research-in-2022/" rel="bookmark" title="Investing In Alzheimer’s Research In 2022" data-wpel-link="internal">Investing In Alzheimer’s Research In 2022</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://southfloridareporter.com/coral-ridge-churchs-loses-attempt-to-overturn-long-held-libel-standards/" rel="bookmark" class="td-image-wrap" title="Coral Ridge Church’s Loses Attempt To Overturn Long-Held Libel Standards" data-wpel-link="internal"><img width="238" height="178" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20238%20178'%3E%3C/svg%3E" data-lazy-srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/3780295748_1170e50cec_w.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/3780295748_1170e50cec_w.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/3780295748_1170e50cec_w.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/3780295748_1170e50cec_w.jpg?resize=238%2C178&ssl=1 238w" data-lazy-sizes="(max-width: 238px) 100vw, 238px" alt="https://www.flickr.com/photos/jikatu/3780295748" title="Coral Ridge Church’s Loses Attempt To Overturn Long-Held Libel Standards" data-lazy-src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/3780295748_1170e50cec_w.jpg?resize=238%2C178&ssl=1" /><noscript><img width="238" height="178" class="entry-thumb" src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/3780295748_1170e50cec_w.jpg?resize=238%2C178&ssl=1"  srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/3780295748_1170e50cec_w.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/3780295748_1170e50cec_w.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/3780295748_1170e50cec_w.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/3780295748_1170e50cec_w.jpg?resize=238%2C178&ssl=1 238w" sizes="(max-width: 238px) 100vw, 238px"  alt="https://www.flickr.com/photos/jikatu/3780295748" title="Coral Ridge Church’s Loses Attempt To Overturn Long-Held Libel Standards" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://southfloridareporter.com/coral-ridge-churchs-loses-attempt-to-overturn-long-held-libel-standards/" rel="bookmark" title="Coral Ridge Church’s Loses Attempt To Overturn Long-Held Libel Standards" data-wpel-link="internal">Coral Ridge Church’s Loses Attempt To Overturn Long-Held Libel Standards</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://southfloridareporter.com/citizens-property-insurance-gets-ok-to-raise-homeowner-rates-6-4-percent-less-than-requested/" rel="bookmark" class="td-image-wrap" title="Citizens Property Insurance Gets OK To Raise Homeowner Rates 6.4 Percent, Less Than Requested" data-wpel-link="internal"><img width="238" height="178" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20238%20178'%3E%3C/svg%3E" data-lazy-srcset="https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 80w, https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 100w, https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 180w, https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 238w, https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 476w, https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 714w" data-lazy-sizes="(max-width: 238px) 100vw, 238px" alt="hope" title="Citizens Property Insurance Gets OK To Raise Homeowner Rates 6.4 Percent, Less Than Requested" data-lazy-src="https://i0.wp.com/southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png?resize=238%2C178&ssl=1" /><noscript><img width="238" height="178" class="entry-thumb" src="https://i0.wp.com/southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png?resize=238%2C178&ssl=1"  srcset="https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 80w, https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 100w, https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 180w, https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 238w, https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 476w, https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2018/10/14075112/aftermath.png 714w" sizes="(max-width: 238px) 100vw, 238px"  alt="hope" title="Citizens Property Insurance Gets OK To Raise Homeowner Rates 6.4 Percent, Less Than Requested" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://southfloridareporter.com/citizens-property-insurance-gets-ok-to-raise-homeowner-rates-6-4-percent-less-than-requested/" rel="bookmark" title="Citizens Property Insurance Gets OK To Raise Homeowner Rates 6.4 Percent, Less Than Requested" data-wpel-link="internal">Citizens Property Insurance Gets OK To Raise Homeowner Rates 6.4 Percent, Less Than Requested</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_9_62bbbdec25c0a" data-td_block_id="td_uid_9_62bbbdec25c0a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_9_62bbbdec25c0a" data-td_block_id="td_uid_9_62bbbdec25c0a"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div class="comments" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/3-everyday-retail-stocks-yielding-over-3/#respond" style="display:none;" data-wpel-link="internal">Cancel reply</a></small></h3><form action="https://southfloridareporter.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
<div class="comment-form-input-wrap td-form-comment">
<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
<div class="td-warning-comment">Please enter your comment!</div>
</div>
<div class="comment-form-input-wrap td-form-author">
<input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-author">Please enter your name here</div>
</div>
<div class="comment-form-input-wrap td-form-email">
<input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-email-error">You have entered an incorrect email address!</div>
<div class="td-warning-email">Please enter your email address here</div>
</div>
<div class="comment-form-input-wrap td-form-url">
<input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
</div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='102397' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="f90d22b205" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="54" /><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><h3><strong>Join Our Newsletter</strong></h3>
<p>Want daily news updates? Just add your email and you&#8217;re on the list. (We will never spam you).</p>
<div class="wpforms-container wpforms-container-full" id="wpforms-100181"><form id="wpforms-form-100181" class="wpforms-validate wpforms-form wpforms-ajax-form" data-formid="100181" method="post" enctype="multipart/form-data" action="/3-everyday-retail-stocks-yielding-over-3/" data-token="f61372655bb8176a05ffcbcc790fbfd3"><noscript class="wpforms-error-noscript">Please enable JavaScript in your browser to complete this form.</noscript><div class="wpforms-field-container"><div id="wpforms-100181-field_2-container" class="wpforms-field wpforms-field-email" data-field-id="2"><label class="wpforms-field-label wpforms-label-hide" for="wpforms-100181-field_2">Email <span class="wpforms-required-label">*</span></label><input type="email" id="wpforms-100181-field_2" class="wpforms-field-large wpforms-field-required" name="wpforms[fields][2]" placeholder="Your Email" required></div></div><div class="wpforms-submit-container"><input type="hidden" name="wpforms[id]" value="100181"><input type="hidden" name="wpforms[author]" value="251"><input type="hidden" name="wpforms[post_id]" value="102397"><button type="submit" name="wpforms[submit]" id="wpforms-submit-100181" class="wpforms-submit" data-alt-text="Sending..." data-submit-text="Subscribe Now" aria-live="assertive" value="wpforms-submit">Subscribe Now</button><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2026%2026'%3E%3C/svg%3E" class="wpforms-submit-spinner" style="display: none;" width="26" height="26" alt="" data-lazy-src="https://southfloridareporter.com/wp-content/plugins/wpforms-lite/assets/images/submit-spin.svg"><noscript><img src="https://southfloridareporter.com/wp-content/plugins/wpforms-lite/assets/images/submit-spin.svg" class="wpforms-submit-spinner" style="display: none;" width="26" height="26" alt=""></noscript></div></form></div> 
</div>
</aside><div class="td-a-rec td-a-rec-id-custom_ad_4  td_uid_12_62bbbdec48078_rand td_block_template_1"></div><div class="td-a-rec td-a-rec-id-custom_ad_3  td_uid_13_62bbbdec481c9_rand td_block_template_1"></div><div class="td-a-rec td-a-rec-id-custom_ad_2  td_uid_15_62bbbdec48333_rand td_block_template_1"><div style="text-align:center;" data-aaad='true' data-aa-adunit='/22181265/sfr_300v_1'></div>
<div style="text-align:center;">&nbsp;</div>

<div>&nbsp;</div>


<div>
<a href="https://www.tinyurl.com/DebtLifePaperback" target="_blank" onclick="ga(&#039;send&#039;, &#039;event&#039;, { eventCategory: &#039;Debt Life - Van Horn - Sidebar&#039;,     eventAction: &#039;click&#039;,     eventLabel: &#039;Debt Life - Van Horn - Sidebar&#039;   }); " data-wpel-link="external" rel="nofollow external noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Debt Life - Van Horn" style="margin:0 auto;" data-lazy-src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2020/06/02002903/Debt-Life-BoxAd-Vanhorn-May2020.jpg" /><noscript><img src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2020/06/02002903/Debt-Life-BoxAd-Vanhorn-May2020.jpg" alt="Debt Life - Van Horn" style="margin:0 auto;"  /></noscript></a>
</div>
<div>&nbsp;</div>
<div>
<a href="http://bitnergroup.com/" target="_blank" onclick="ga(&#039;send&#039;, &#039;event&#039;, { eventCategory: &#039;Bitner Group Sidebar&#039;,     eventAction: &#039;click&#039;,     eventLabel: &#039;Bitner Group - Sidebar&#039;   }); " data-wpel-link="external" rel="nofollow external noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="The Bitner Group" style="margin:0 auto;" data-lazy-src="https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2021/02/17012418/BitnerGroup-Ad-2021-Box-Ad.png" /><noscript><img src="https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2021/02/17012418/BitnerGroup-Ad-2021-Box-Ad.png" alt="The Bitner Group" style="margin:0 auto;"  /></noscript></a>
</div>



<div>&nbsp;</div>
<div>
<a href="https://www.vanhornlawgroup.com" target="_blank" onclick="ga(&#039;send&#039;, &#039;event&#039;, { eventCategory: &#039;Box Ad - Lincoln - Van Horn &#039;, eventAction: &#039;click&#039;, eventLabel: &#039;Box-Lincoln-Ad&#039; }); " data-wpel-link="external" rel="nofollow external noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Van Horn Law Group, P.A. - Losing Your Home? " title="Van Horn Law Group, P.A. - Losing Your Home? " style="max-width:100%; margin:0 auto;" data-lazy-src="https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2021/07/15123915/Foreclosure-BoxAd-VanHorn-AS.jpg" /><noscript><img src="https://southfloridareporter.s3.amazonaws.com/wp-content/uploads/2021/07/15123915/Foreclosure-BoxAd-VanHorn-AS.jpg" alt="Van Horn Law Group, P.A. - Losing Your Home? " title="Van Horn Law Group, P.A. - Losing Your Home? " style="max-width:100%; margin:0 auto;" /></noscript></a>
</div>
<div>&nbsp;</div>
<div>
<a href="https://southfloridareporter.com/coronavirus/" onclick="ga(&#039;send&#039;, &#039;event&#039;, { eventCategory: &#039;Coronavirus News  Box Ad - Sidebar&#039;,     eventAction: &#039;click&#039;,     eventLabel: &#039;Surfshark Box Ad - Sidebar&#039;   }); " data-wpel-link="internal"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20325%20250'%3E%3C/svg%3E" alt="Coronavirus News" title="Coronavirus News" style="max-width:100%; margin:0 auto;" width="325" height="250" data-lazy-src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2020/04/01024052/coronavirus.png" /><noscript><img src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2020/04/01024052/coronavirus.png" alt="Coronavirus News" title="Coronavirus News" style="max-width:100%; margin:0 auto;" width="325" height="250" /></noscript></a></div>
<div>&nbsp;</div>
<div class="">
<a href="https://southfloridareporter.com/test-drive/" onclick="ga(&#039;send&#039;, &#039;event&#039;, { eventCategory: &#039;Outbound Link&#039;, eventAction: &#039;click&#039;, eventLabel: &#039;TestDriveNow&#039; }); " data-wpel-link="internal"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/08/17090637/TDN-300x250.jpg" /><noscript><img src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/08/17090637/TDN-300x250.jpg" alt="" /></noscript></a>
</div>
<div style="margin: 5px 20px; font-size: 12px"><b>America's best resource to research and decide on your next new car, truck, or SUV.</div>
<div>&nbsp;</div>
<div class="">
<a href="https://myhappyheadlines.com" onclick="ga(&#039;send&#039;, &#039;event&#039;, { eventCategory: &#039;Outbound Link&#039;, eventAction: &#039;click&#039;, eventLabel: &#039;Happy Headlines Box Ad }); " data-wpel-link="external" rel="nofollow external noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2019/06/01131530/450-HH-Box.png" /><noscript><img src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2019/06/01131530/450-HH-Box.png" alt="" /></noscript></a>
</div>
<div>&nbsp;</div>
<div style="text-align:center;" data-aaad='true' data-aa-adunit='/22181265/sfr_siderail_sticky'></div></div>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar td_uid_18_62bbbdec484a7_rand td_block_template_1">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1024 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-3799504456100090" data-ad-slot="5299248569"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
                    if ( td_screen_width >= 768  && td_screen_width < 1024 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-3799504456100090" data-ad-slot="5299248569"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-3799504456100090" data-ad-slot="5299248569"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

<div class="td_block_wrap td_block_text_with_title td_block_widget td_uid_19_62bbbdec48828_rand td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_19_62bbbdec48828"><div class="td_mod_wrap td-pb-padding-side td-fix-index"><script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "600";
   medianet_crid = "465448418";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CU2B687D' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div><aside class="td_block_template_1 widget ai_widget ai-sticky-widget"><div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<div data-aaad='true' data-aa-adunit='/22181265/sfr_mob_300v_2'></div></div>
</aside> </div>
</div>
</div> 
</div>
</div> 


<div class="td-footer-container td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span4">
<div class="td-footer-info td-pb-padding-side"><div class="footer-logo-wrap"><a href="https://southfloridareporter.com/" data-wpel-link="internal"><img class="td-retina-data" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20230%200'%3E%3C/svg%3E" data-retina="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/06/17014216/footer1.png" alt="" title="" width="230" data-lazy-src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/06/17014216/footer1.png" /><noscript><img class="td-retina-data" src="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/06/17014216/footer1.png" data-retina="https://s3.amazonaws.com/southfloridareporter/wp-content/uploads/2015/06/17014216/footer1.png" alt="" title="" width="230" /></noscript></a></div><div class="footer-text-wrap">Welcome to South Florida Reporter, your go-to source for news and information for the Sunshine State. </div><div class="footer-social-wrap td-social-style2">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/southfloridareporter?fref=ts" title="Facebook" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SFlReporter" title="Twitter" data-wpel-link="external" rel="nofollow external noopener noreferrer">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div></div> </div>
<div class="td-pb-span4">
<div class="td_block_wrap td_block_7 td_uid_21_62bbbdec95e33_rand td_block_template_1" data-td-block-uid="td_uid_21_62bbbdec95e33"><script>var block_td_uid_21_62bbbdec95e33 = new tdBlock();
block_td_uid_21_62bbbdec95e33.id = "td_uid_21_62bbbdec95e33";
block_td_uid_21_62bbbdec95e33.atts = '{"custom_title":"EVEN MORE NEWS","border_top":"no_border_top","limit":3,"separator":"","custom_url":"","block_template_id":"","color_preset":"","m6_tl":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","offset":"","show_modified_date":"","el_class":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","class":"td_uid_21_62bbbdec95e33_rand","tdc_css_class":"td_uid_21_62bbbdec95e33_rand","tdc_css_class_style":"td_uid_21_62bbbdec95e33_rand_style"}';
block_td_uid_21_62bbbdec95e33.td_column_number = "1";
block_td_uid_21_62bbbdec95e33.block_type = "td_block_7";
block_td_uid_21_62bbbdec95e33.post_count = "3";
block_td_uid_21_62bbbdec95e33.found_posts = "19703";
block_td_uid_21_62bbbdec95e33.header_color = "";
block_td_uid_21_62bbbdec95e33.ajax_pagination_infinite_stop = "";
block_td_uid_21_62bbbdec95e33.max_num_pages = "6568";
tdBlocksArray.push(block_td_uid_21_62bbbdec95e33);
</script><h4 class="block-title"><span class="td-pulldown-size">EVEN MORE NEWS</span></h4><div id=td_uid_21_62bbbdec95e33 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://southfloridareporter.com/afternoon-showers-and-storms-for-florida-wednesday-watching-the-tropics/" rel="bookmark" class="td-image-wrap" title="Afternoon Showers And Storms For Florida Wednesday; Watching The Tropics" data-wpel-link="internal"><img width="100" height="75" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2075'%3E%3C/svg%3E" data-lazy-srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?zoom=3&resize=100%2C75&ssl=1 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" alt="https://www.freepik.com/premium-photo/summer-thunderstorms_4597655.htm#query=stormy&amp;position=9&amp;from_view=search" title="Afternoon Showers And Storms For Florida Wednesday; Watching The Tropics" data-lazy-src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?resize=100%2C75&ssl=1" /><noscript><img width="100" height="75" class="entry-thumb" src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?resize=100%2C75&ssl=1"  srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/summer-thunderstorms.jpg?zoom=3&resize=100%2C75&ssl=1 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="https://www.freepik.com/premium-photo/summer-thunderstorms_4597655.htm#query=stormy&amp;position=9&amp;from_view=search" title="Afternoon Showers And Storms For Florida Wednesday; Watching The Tropics" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://southfloridareporter.com/afternoon-showers-and-storms-for-florida-wednesday-watching-the-tropics/" rel="bookmark" title="Afternoon Showers And Storms For Florida Wednesday; Watching The Tropics" data-wpel-link="internal">Afternoon Showers And Storms For Florida Wednesday; Watching The Tropics</a></h3> <div class="meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-28T20:05:32+00:00">Jun 28, 2022</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://southfloridareporter.com/from-under-to-on-the-rocks-invasive-crabs-become-whiskey/" rel="bookmark" class="td-image-wrap" title="From Under To On The Rocks: Invasive Crabs Become Whiskey" data-wpel-link="internal"><img width="100" height="75" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2075'%3E%3C/svg%3E" data-lazy-srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?zoom=3&resize=100%2C75&ssl=1 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" alt="" title="From Under To On The Rocks: Invasive Crabs Become Whiskey" data-lazy-src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=100%2C75&ssl=1" /><noscript><img width="100" height="75" class="entry-thumb" src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=100%2C75&ssl=1"  srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/1000-6.jpeg?zoom=3&resize=100%2C75&ssl=1 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="From Under To On The Rocks: Invasive Crabs Become Whiskey" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://southfloridareporter.com/from-under-to-on-the-rocks-invasive-crabs-become-whiskey/" rel="bookmark" title="From Under To On The Rocks: Invasive Crabs Become Whiskey" data-wpel-link="internal">From Under To On The Rocks: Invasive Crabs Become Whiskey</a></h3> <div class="meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-28T20:00:17+00:00">Jun 28, 2022</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://southfloridareporter.com/undetected-high-cholesterol-found-in-2-out-of-3-stroke-patients/" rel="bookmark" class="td-image-wrap" title="Undetected High Cholesterol Found In 2 Out Of 3 Stroke Patients" data-wpel-link="internal"><img width="100" height="75" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2075'%3E%3C/svg%3E" data-lazy-srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?zoom=3&resize=100%2C75&ssl=1 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" alt="https://www.vecteezy.com/photo/4623178-visit-to-cardiologist" title="Undetected High Cholesterol Found In 2 Out Of 3 Stroke Patients" data-lazy-src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=100%2C75&ssl=1" /><noscript><img width="100" height="75" class="entry-thumb" src="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=100%2C75&ssl=1"  srcset="https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=80%2C60&ssl=1 80w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=100%2C75&ssl=1 100w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=180%2C135&ssl=1 180w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?resize=238%2C178&ssl=1 238w, https://i0.wp.com/southfloridareporter.com/wp-content/uploads/2022/06/vecteezy_visit-to-cardiologist__885.jpg?zoom=3&resize=100%2C75&ssl=1 300w" sizes="(max-width: 100px) 100vw, 100px"  alt="https://www.vecteezy.com/photo/4623178-visit-to-cardiologist" title="Undetected High Cholesterol Found In 2 Out Of 3 Stroke Patients" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://southfloridareporter.com/undetected-high-cholesterol-found-in-2-out-of-3-stroke-patients/" rel="bookmark" title="Undetected High Cholesterol Found In 2 Out Of 3 Stroke Patients" data-wpel-link="internal">Undetected High Cholesterol Found In 2 Out Of 3 Stroke Patients</a></h3> <div class="meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-28T19:55:35+00:00">Jun 28, 2022</time></span> </div>
</div>
</div>
</div> </div></div>  </div>
<div class="td-pb-span4">
<div class="td_block_wrap td_block_popular_categories td_uid_22_62bbbdec98157_rand widget widget_categories td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_22_62bbbdec98157"><h4 class="block-title"><span class="td-pulldown-size">POPULAR CATEGORY</span></h4><ul class="td-pb-padding-side"><li><a href="https://southfloridareporter.com/consumer/" data-wpel-link="internal">Consumer<span class="td-cat-no">3812</span></a></li><li><a href="https://southfloridareporter.com/articles/" data-wpel-link="internal">Articles<span class="td-cat-no">2877</span></a></li><li><a href="https://southfloridareporter.com/weather/" data-wpel-link="internal">Weather<span class="td-cat-no">2645</span></a></li><li><a href="https://southfloridareporter.com/today-is/" data-wpel-link="internal">Today Is<span class="td-cat-no">2387</span></a></li><li><a href="https://southfloridareporter.com/health/" data-wpel-link="internal">Health<span class="td-cat-no">2326</span></a></li><li><a href="https://southfloridareporter.com/video/" data-wpel-link="internal">Video<span class="td-cat-no">2104</span></a></li><li><a href="https://southfloridareporter.com/news/" data-wpel-link="internal">News<span class="td-cat-no">1937</span></a></li></ul></div>  </div>
</div>
</div>

<div class="td-sub-footer-container td-container td-container-border ">
<div class="td-pb-row">
<div class="td-pb-span8 td-sub-footer-menu">
<div class="td-pb-padding-side">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-21609" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-21609"><a href="https://southfloridareporter.com/who-we-are/" data-wpel-link="internal">Who We Are</a></li>
<li id="menu-item-21608" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-21608"><a href="https://southfloridareporter.com/our-contributing-partners/" data-wpel-link="internal">Our Partners</a></li>
<li id="menu-item-495" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-495"><a href="https://southfloridareporter.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li id="menu-item-496" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-496"><a href="https://southfloridareporter.com/terms-of-use/" data-wpel-link="internal">Terms of Use</a></li>
<li id="menu-item-499" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-499"><a href="https://southfloridareporter.com/td_d_slug_15/" data-wpel-link="internal">Contact Us</a></li>
</ul></div> </div>
</div>
<div class="td-pb-span4 td-sub-footer-copy">
<div class="td-pb-padding-side">
&copy; Copyright 2015-2021 - South Florida Reporter.
 </div>
</div>
</div>
</div>
</div>
</div>


<style type="text/css" media="screen">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</style>
<script type="text/javascript">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</script><link rel='stylesheet' id='vc_font_awesome_5_shims-css' href='https://southfloridareporter.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/v4-shims.min.css?ver=6.9.0' type='text/css' media='all' />
<link rel='stylesheet' id='vc_font_awesome_5-css' href='https://southfloridareporter.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/all.min.css?ver=6.9.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpforms-full-css' href='https://southfloridareporter.com/wp-content/plugins/wpforms-lite/assets/css/wpforms-full.min.css?ver=1.7.4.2' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/11.0/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/es_template\/new-post-published-posttitle-3\/|\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/southfloridareporter.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' src='https://southfloridareporter.com/wp-content/plugins/td-composer/legacy/common/wp_booster/js_dev/tdModalPostImages.js?ver=4.9' id='tdModalPostImages-js'></script>
<script type='text/javascript' src='https://southfloridareporter.com/wp-content/plugins/td-composer/legacy/Newsmag/js/tagdiv_theme.min.js?ver=4.9' id='td-site-min-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://southfloridareporter.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=f5a9d453c5a79e347f9ee90353c1abdf' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://southfloridareporter.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=25eafb3f2ad93939cdfaaa7782cb8b85' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' id='wpb_composer_front_js-js-extra'>
/* <![CDATA[ */
var vcData = {"currentTheme":{"slug":"Newsmag"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://southfloridareporter.com/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=6.9.0' id='wpb_composer_front_js-js'></script>
<script type='text/javascript' src='https://southfloridareporter.com/wp-content/plugins/wpforms-lite/assets/js/jquery.validate.min.js?ver=1.19.3' id='wpforms-validation-js'></script>
<script type='text/javascript' src='https://southfloridareporter.com/wp-content/plugins/wpforms-lite/assets/js/mailcheck.min.js?ver=1.1.2' id='wpforms-mailcheck-js'></script>
<script type='text/javascript' src='https://southfloridareporter.com/wp-content/plugins/wpforms-lite/assets/js/punycode.min.js?ver=1.0.0' id='wpforms-punycode-js'></script>
<script type='text/javascript' src='https://southfloridareporter.com/wp-content/plugins/wpforms-lite/assets/js/wpforms.min.js?ver=1.7.4.2' id='wpforms-js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpforms_settings = {"val_required":"This field is required.","val_email":"Please enter a valid email address.","val_email_suggestion":"Did you mean {suggestion}?","val_email_suggestion_title":"Click to accept this suggestion.","val_email_restricted":"This email address is not allowed.","val_number":"Please enter a valid number.","val_number_positive":"Please enter a valid positive number.","val_confirm":"Field values do not match.","val_checklimit":"You have exceeded the number of allowed selections: {#}.","val_limit_characters":"{count} of {limit} max characters.","val_limit_words":"{count} of {limit} max words.","val_recaptcha_fail_msg":"Google reCAPTCHA verification failed, please try again later.","val_empty_blanks":"Please fill out all blanks.","uuid_cookie":"","locale":"en","wpforms_plugin_url":"https:\/\/southfloridareporter.com\/wp-content\/plugins\/wpforms-lite\/","gdpr":"","ajaxurl":"https:\/\/southfloridareporter.com\/wp-admin\/admin-ajax.php","mailcheck_enabled":"1","mailcheck_domains":[],"mailcheck_toplevel_domains":["dev"],"is_ssl":"1"}
/* ]]> */
</script>

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[102397]");
                });
            
</script>
<script src='https://stats.wp.com/e-202226.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.0',blog:'207523558',post:'102397',tz:'-4',srv:'southfloridareporter.com'} ]);
	_stq.push([ 'clickTrackerInit', '207523558', '102397' ]);
</script>
<script>
  if (document.getElementsByTagName("body")){
          nodoUno = document.getElementsByTagName("body");
          nodoUno[0].insertAdjacentHTML('afterbegin', "<div data-aaad='true' data-aa-adunit='/22181265/sfr_Skin'></div>");
        }
</script><script>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</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://southfloridareporter.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'722b87d72d885c70',m:'kUCWK2RR4OJQnStLQ7V7NWSejy67LijJYlq3c_TT35Q-1656472871-0-AW7WIVCYIzKMCKl5xhlYnfxMCSVjMtkxJJ/A9aONwRf2dj6HwnrIATYtOguzYcHUEKJ5RkCy5ZbTSTF9yzzGmlMp58jWOzS7IKspDPVNOBTGE4G2l9Y9bqlew2SodwND0mAjIfmrxh0BT3V08/J0WdczDS/MeaacgEgX3bX5KHzX',s:[0x1ac7c652e9,0x6e8a1c2581],u:'/cdn-cgi/challenge-platform/h/b'}})();</script></body>
</html>
